2525c power indicator light not working (amp does)

Silver Jubilee amps, 2555x 2558, 2550, 2553, 2555, 2525H, 2525C

Moderator: longfxukxnhair


jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

2525c power indicator light not working (amp does)

Postby jonnymags » 06 May 2017, 06:37

I replaced the ht fuse in case but still no red light. Any ideas? Cheers!

Roger
Gold Member
Gold Member
User avatar
Posts: 577
Joined: 20 Nov 2015, 04:25
Location: Catalonia
Has Liked: 894 times
Been liked: 295 times

Re: 2525c power indicator light not working (amp does)

Postby Roger » 06 May 2017, 06:46

I don't know but seems to be the light it's burn out. It's rare but can happened.
:whatever. SORRY for english level
MARSHALL:TSL100/6100LM/JCM900 MKIII 50w/VM2466/JVM1H/
Lead12 5005(moded)
Lead 1960A/1965A/Vintage 1936/Lead 1936
Blackheart BH15H(moded) 7W-15W
Madamp J5MK1(moded 5W-10W)
Arial 4X12 60W
Peavey XRD680
:Cheers

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 06 May 2017, 06:51

Thanks. Oddly when it first happened I plugged amp in and no light. Unplugged and plugged back in and it worked for few seconds before going out again. Now nothing...

(Apparently the VMs had an issue with LED lights going... Similar?)

Roger
Gold Member
Gold Member
User avatar
Posts: 577
Joined: 20 Nov 2015, 04:25
Location: Catalonia
Has Liked: 894 times
Been liked: 295 times

Re: 2525c power indicator light not working (amp does)

Postby Roger » 06 May 2017, 09:23

The power switch carries the built-in light. On the VMs doesn't. In the jubilee It's difficult take out and works in different voltage.
IMO the best solution is replace the power switch.
:whatever. SORRY for english level
MARSHALL:TSL100/6100LM/JCM900 MKIII 50w/VM2466/JVM1H/
Lead12 5005(moded)
Lead 1960A/1965A/Vintage 1936/Lead 1936
Blackheart BH15H(moded) 7W-15W
Madamp J5MK1(moded 5W-10W)
Arial 4X12 60W
Peavey XRD680
:Cheers

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 06 May 2017, 10:32

Thanks Roger. Aww that means doing something electrical and I'm no good at that!

Roger
Gold Member
Gold Member
User avatar
Posts: 577
Joined: 20 Nov 2015, 04:25
Location: Catalonia
Has Liked: 894 times
Been liked: 295 times

Re: 2525c power indicator light not working (amp does)

Postby Roger » 06 May 2017, 11:53

jonnymags wrote:Thanks Roger. Aww that means doing something electrical and I'm no good at that!


Buy few years ago a pair of Chinese that are almost equal but do not make the same intensity of light. I bought them to install in isolated transformer and in voltage stabilizer, both had the same switch format like Marshall but without light. One fused the light, disassembled it, the bulb was fused, could not be reassembled. You will have many marks on the plastic. You can try it but I think replace it's best.
:whatever. SORRY for english level
MARSHALL:TSL100/6100LM/JCM900 MKIII 50w/VM2466/JVM1H/
Lead12 5005(moded)
Lead 1960A/1965A/Vintage 1936/Lead 1936
Blackheart BH15H(moded) 7W-15W
Madamp J5MK1(moded 5W-10W)
Arial 4X12 60W
Peavey XRD680
:Cheers

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 06 May 2017, 13:28

Could it be a fuse gone in the actual mains input on back of amp - manual says it has an integrated fuse compartment ...

Roger
Gold Member
Gold Member
User avatar
Posts: 577
Joined: 20 Nov 2015, 04:25
Location: Catalonia
Has Liked: 894 times
Been liked: 295 times

Re: 2525c power indicator light not working (amp does)

Postby Roger » 06 May 2017, 14:45

jonnymags wrote:Could it be a fuse gone in the actual mains input on back of amp - manual says it has an integrated fuse compartment ...


Sorry I understood that the amp works properly and the power switch light doesn't. Yes this fuse on the mains input on back of the amp a it's a replacemt. Could be the mains fuse is burned out if the amp doesn't works . Take care if this fuses are the same amperage ratling. how you see the mains fuse? Is it ok? Could be the mains cable.
:whatever. SORRY for english level
MARSHALL:TSL100/6100LM/JCM900 MKIII 50w/VM2466/JVM1H/
Lead12 5005(moded)
Lead 1960A/1965A/Vintage 1936/Lead 1936
Blackheart BH15H(moded) 7W-15W
Madamp J5MK1(moded 5W-10W)
Arial 4X12 60W
Peavey XRD680
:Cheers

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 06 May 2017, 23:43

thanks but the amp works fine. On the back there is the HT fuse. Then there's the mains input which says it has an integrated compartment for two additional fuses. If the power light is mains powered could a fuse in the mains compartment have blown?

Roger
Gold Member
Gold Member
User avatar
Posts: 577
Joined: 20 Nov 2015, 04:25
Location: Catalonia
Has Liked: 894 times
Been liked: 295 times

Re: 2525c power indicator light not working (amp does)

Postby Roger » 06 May 2017, 23:54

If the amp works. I don't think so. I think it's the bulb on the power switch.
:whatever. SORRY for english level
MARSHALL:TSL100/6100LM/JCM900 MKIII 50w/VM2466/JVM1H/
Lead12 5005(moded)
Lead 1960A/1965A/Vintage 1936/Lead 1936
Blackheart BH15H(moded) 7W-15W
Madamp J5MK1(moded 5W-10W)
Arial 4X12 60W
Peavey XRD680
:Cheers

Anitoli
Knighted
Knighted
User avatar
Posts: 3481
Joined: 05 May 2013, 12:35
Location: Lewiston, Maine
Has Liked: 1827 times
Been liked: 1659 times
Contact:

Re: 2525c power indicator light not working (amp does)

Postby Anitoli » 07 May 2017, 00:38

Some of the lighted power switches use neon bulbs, whose life expectancy is hit or miss.

You might find one here:

http://www.amprepairparts.com/switches.htm

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 07 May 2017, 01:47

Cheers. I might give Marshall a phone call and order correct switch from them (I'm in uk and live not far from the factory)...

jonnymags
<100 Posts
<100 Posts
Posts: 29
Joined: 26 Jan 2010, 13:18
Been liked: 3 times

Re: 2525c power indicator light not working (amp does)

Postby jonnymags » 23 May 2017, 13:06

So I have to send back to shop to go back to Marshall as still under warranty. However the amp, sensing it might need some surgery decided, this weekend, to make the red light start working again (albeit dimly). Huh?

Return to “Marshall 25th Anniversarary Silver Jubilee (RI)”

Who is online

Users browsing this forum: No registered users and 1 guest